What Version?

Conkeror 1.0 depends on XULRunner 1.9.1 or higher.

Conkeror 0.9.x depends on XULRunner 1.9.0 or higher.

The best is to use a stable released version. Unreleased development versions may have breaking changes for which Conkeror has not yet been updated.