Version Notes

Version 2.5.9rc2

It is necessary both to add a conkeror entry to install.rdf, and to delete the META-INF directory, as described in Extensions.

Version 2.6.5

Conkeror's noscript.js is apparently not compatible with NoScript 2.6.5. See issue441

Version 2.6.9.22

NoScript 2.6.9.22 seems to work fine with Conkeror 1.0pre1 in Debian Jessie, where it is run on top of Firefox (called Iceweasel in Debian) instead of XULrunner. The only challenge is getting Conkeror to install NoScript, but this can be brute forced by editing Conkeror's application.ini manifest (/usr/share/conkeror/application.ini) so that it identifies itself as Firefox (changing the ID to ec8030f7-c20a-464f-9b0e-13a3a9e97384 and version to 31.6.0). Once that's done, download the NoScript xpi and visit the file in Conkeror to install it.