welcome: please sign in

Please enter your password of your account at the remote wiki below.
/!\ You should trust both wikis because the password could be read by the particular administrators.

Clear message
location: LastPass

LastPass is not yet compatible with Conkeror, but it doesn't look all that hard. Here are some notes.

* lastpass
** has META_INF
** overlays
*** lastpass.xul

loads getlp.js

window.addEventListener("load", LP.lpToolbarInit, false);

*** statusbar.xul

loads getlp.js

** install.rdf

has toolkit support, but only 1.9a2 through 1.9.6 (that's odd)

Installs by deleting META_INF from the xpi and adding a Conkeror stanza to install.rdf as described on Extensions.

This goes in chrome.manifest:

overlay chrome://conkeror-gui/content/conkeror.xul chrome://lastpass/content/lastpass.xul

Then after I restarted Conkeror, a LastPass dialog came up to guide me through account creation. A few errors were spewed to the console, though.

This error could be a tricky one. It indicates that LastPass expects to find a xul:tabbrowser in the window, but Conkeror does not use one of those.

Console error: [JavaScript Error: "LP.mostRecent().getBrowser().addTab is not a function" ...